refactor(CommandInteractionOptionResolver): remove getFull from getFocused() #9789
Add this suggestion to a batch that can be applied as a single commit.
This suggestion is invalid because no changes were made to the code.
Suggestions cannot be applied while the pull request is closed.
Suggestions cannot be applied while viewing a subset of changes.
Only one suggestion per line can be applied in a batch.
Add this suggestion to a batch that can be applied as a single commit.
Applying suggestions on deleted lines is not supported.
You must change the existing code in this line in order to create a valid suggestion.
Outdated suggestions cannot be applied.
This suggestion has been applied or marked resolved.
Suggestions cannot be applied from pending reviews.
Suggestions cannot be applied on multi-line comments.
Suggestions cannot be applied while the pull request is queued to merge.
Suggestion cannot be applied right now. Please check back later.
Please describe the changes this PR makes and why it should be merged:
This PR removes the argument for getFull in CommandInteractionOptionResolver#getFocused and instead makes the function always return the full object. This change was discussed in a thread in the DJS Discord server and the reason I am opening this PR is because I personally have never found a use case where I don't need the name of the option, and everyone should always check that property in their code in order to future-proof it in the event that a command ever gets 2 options with autocomplete with different names and different behaviors. I am also open to feedback as another option I considered in that thread was to change the default of this parameter to true instead of false, thus leaving this shortcut for the people that want to be less safe about their code but still making the default the recommended and more common behavior.
Status and versioning classification: